using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{8})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=[\w\d[:punct:]]+$)";
string input = @"2_Sh0rt
NO_LOW3RCASE
No_Numbers
n0_uppercase
This_1s_my_p@ssword
This_1s_@n_apple🍎";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}