import re
regex = re.compile(r"^(?=.{8})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=[\w\d[:punct:]]+$)", flags=re.MULTILINE)
test_str = ("2_Sh0rt\n"
"NO_LOW3RCASE\n"
"No_Numbers\n"
"n0_uppercase\n"
"This_1s_my_p@ssword\n"
"This_1s_@n_apple🍎")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")