const regex = /^(?=.{8})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=[\w\d[:punct:]]+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{8})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=[\\w\\d[:punct:]]+$)', 'gm')
const str = `2_Sh0rt
NO_LOW3RCASE
No_Numbers
n0_uppercase
This_1s_my_p@ssword
This_1s_@n_apple🍎`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}