#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*B$"
Local $sString = "Ronald Mayr: A" & @CRLF & _
"Bell Kassulke: B" & @CRLF & _
"Jacqueline Rupp: A" & @CRLF & _
"Alexander Beller: C" & @CRLF & _
"Valentina Denk: C" & @CRLF & _
"Simon Loidl: B" & @CRLF & _
"Elias Jovanovic: B" & @CRLF & _
"Stefanie Weninger: A" & @CRLF & _
"Fabian Peer: C" & @CRLF & _
"Hakim Botros: B" & @CRLF & _
"Emilie Lorentsen: B" & @CRLF & _
"Herman Karlsen: C "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")