import re
regex = re.compile(r"^.*B$", flags=re.MULTILINE)
test_str = ("Ronald Mayr: A\n"
"Bell Kassulke: B\n"
"Jacqueline Rupp: A\n"
"Alexander Beller: C\n"
"Valentina Denk: C\n"
"Simon Loidl: B\n"
"Elias Jovanovic: B\n"
"Stefanie Weninger: A\n"
"Fabian Peer: C\n"
"Hakim Botros: B\n"
"Emilie Lorentsen: B\n"
"Herman Karlsen: C ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")