re = /^.*B$/m
str = 'Ronald Mayr: A
Bell Kassulke: B
Jacqueline Rupp: A
Alexander Beller: C
Valentina Denk: C
Simon Loidl: B
Elias Jovanovic: B
Stefanie Weninger: A
Fabian Peer: C
Hakim Botros: B
Emilie Lorentsen: B
Herman Karlsen: C '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end