#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^- ([^\r\n-]*) - ([^\r\n-]*) - Coord\."
Local $sString = "Fica outorgada, em nome da PREFEITURA MUNICIPAL DE" & @CRLF & _
"JUQUIÁ, CNPJ n. 46.585.964/0001-40, a autorização administrativa para interferência(s) em recursos hídricos superficiais, para" & @CRLF & _
"fins de rodoviário no município de JUQUIÁ, conforme abaixo" & @CRLF & _
"identificado:" & @CRLF & _
"- Travessia Aérea 01 - Afluente do Rio Juquiá - Coord." & @CRLF & _
"Geográficas Latitude S 24° 19' 54,00" - Longitude o 47° 38'" & @CRLF & _
"54,10" - Prazo 30 anos." & @CRLF & _
"- Travessia Aérea 02 - Afluente do Rio Juquiá - Coord." & @CRLF & _
"Geográficas Latitude S 24° 19' 58,00" - Longitude o 47° 38'" & @CRLF & _
"52,20" - Prazo 30 anos." & @CRLF & _
"- Travessia Aérea 03 - Afluente do Rio Juquiá - Coord." & @CRLF & _
"Geográficas Latitude S 24° 19' 58,00" - Longitude o 47° 38'" & @CRLF & _
"52,00" - Prazo 30 anos." & @CRLF & _
"- Travessia Aérea 04 - Afluente do Rio Juquiá - Coord." & @CRLF & _
"Geográficas Latitude S 24° 19' 59,00" - Longitude o 47° 38'" & @CRLF & _
"51,70" - Prazo 30 anos." & @CRLF & _
"- Travessia Aérea 05 - Afluente do Rio Juquiá - Coord." & @CRLF & _
"Geográficas Latitude S 24° 19' 59,40" - Longitude o 47° 38'" & @CRLF & _
"51,50" - Prazo 30 anos." & @CRLF & _
"- Travessia Aérea 06 - Afluente do Rio Juquiá - Coord." & @CRLF & _
"Geográficas Latitude S 24° 19' 59,90" - Longitude o 47° 38'" & @CRLF & _
"51,30" - Prazo 30 anos. Processo DAEE 9502113 - Extrato de" & @CRLF & _
"Portaria 4063/19."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")