use strict;
my $str = 'Fica outorgada, em nome da PREFEITURA MUNICIPAL DE
JUQUIÁ, CNPJ n. 46.585.964/0001-40, a autorização administrativa para interferência(s) em recursos hídricos superficiais, para
fins de rodoviário no município de JUQUIÁ, conforme abaixo
identificado:
- Travessia Aérea 01 - Afluente do Rio Juquiá - Coord.
Geográficas Latitude S 24° 19\' 54,00" - Longitude o 47° 38\'
54,10" - Prazo 30 anos.
- Travessia Aérea 02 - Afluente do Rio Juquiá - Coord.
Geográficas Latitude S 24° 19\' 58,00" - Longitude o 47° 38\'
52,20" - Prazo 30 anos.
- Travessia Aérea 03 - Afluente do Rio Juquiá - Coord.
Geográficas Latitude S 24° 19\' 58,00" - Longitude o 47° 38\'
52,00" - Prazo 30 anos.
- Travessia Aérea 04 - Afluente do Rio Juquiá - Coord.
Geográficas Latitude S 24° 19\' 59,00" - Longitude o 47° 38\'
51,70" - Prazo 30 anos.
- Travessia Aérea 05 - Afluente do Rio Juquiá - Coord.
Geográficas Latitude S 24° 19\' 59,40" - Longitude o 47° 38\'
51,50" - Prazo 30 anos.
- Travessia Aérea 06 - Afluente do Rio Juquiá - Coord.
Geográficas Latitude S 24° 19\' 59,90" - Longitude o 47° 38\'
51,30" - Prazo 30 anos. Processo DAEE 9502113 - Extrato de
Portaria 4063/19.';
my $regex = qr/^- ([^\r\n-]*) - ([^\r\n-]*) - Coord\./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}