import re
regex = re.compile(r"^- ([^\r\n-]*) - ([^\r\n-]*) - Coord\.", flags=re.MULTILINE)
test_str = ("Fica outorgada, em nome da PREFEITURA MUNICIPAL DE\n"
"JUQUIÁ, CNPJ n. 46.585.964/0001-40, a autorização administrativa para interferência(s) em recursos hídricos superficiais, para\n"
"fins de rodoviário no município de JUQUIÁ, conforme abaixo\n"
"identificado:\n"
"- Travessia Aérea 01 - Afluente do Rio Juquiá - Coord.\n"
"Geográficas Latitude S 24° 19' 54,00\" - Longitude o 47° 38'\n"
"54,10\" - Prazo 30 anos.\n"
"- Travessia Aérea 02 - Afluente do Rio Juquiá - Coord.\n"
"Geográficas Latitude S 24° 19' 58,00\" - Longitude o 47° 38'\n"
"52,20\" - Prazo 30 anos.\n"
"- Travessia Aérea 03 - Afluente do Rio Juquiá - Coord.\n"
"Geográficas Latitude S 24° 19' 58,00\" - Longitude o 47° 38'\n"
"52,00\" - Prazo 30 anos.\n"
"- Travessia Aérea 04 - Afluente do Rio Juquiá - Coord.\n"
"Geográficas Latitude S 24° 19' 59,00\" - Longitude o 47° 38'\n"
"51,70\" - Prazo 30 anos.\n"
"- Travessia Aérea 05 - Afluente do Rio Juquiá - Coord.\n"
"Geográficas Latitude S 24° 19' 59,40\" - Longitude o 47° 38'\n"
"51,50\" - Prazo 30 anos.\n"
"- Travessia Aérea 06 - Afluente do Rio Juquiá - Coord.\n"
"Geográficas Latitude S 24° 19' 59,90\" - Longitude o 47° 38'\n"
"51,30\" - Prazo 30 anos. Processo DAEE 9502113 - Extrato de\n"
"Portaria 4063/19.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")