package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([a-z0-9]+[!#$%&'*+-/=?^_`{|]?)+@([a-z0-9-]).+([a-z0-9-])$`)
var str = `a6!a11!@a3h.com-a.a.unin
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}