$re = '/^([a-z0-9]+[!#$%&\'*+-/=?^_`{|]?)+@([a-z0-9-]).+([a-z0-9-])$/im';
$str = 'a6!a11!@a3h.com-a.a.unin
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);