// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^([a-z0-9]+[!#$%&'*+-/=?^_`{|]?)+@([a-z0-9-]).+([a-z0-9-])$").unwrap();
let string = "a6!a11!@a3h.com-a.a.unin
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}