#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=-)\d+x\d+(?=\.[^.]*$)"
Local $sString = "https://ensia.com/wp-content/uploads/2020/08/abc_def_ghi-167x378.jpg" & @CRLF & _
"https://ensia.com/wp-content/uploads/2020/08/abc-190x233-def_ghi-127x3278.jpg"
Local $sSubst = "920x458"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)