$re = '/(?<=-)\d+x\d+(?=\.[^.]*$)/m';
$str = 'https://ensia.com/wp-content/uploads/2020/08/abc_def_ghi-167x378.jpg
https://ensia.com/wp-content/uploads/2020/08/abc-190x233-def_ghi-127x3278.jpg';
$subst = "920x458";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;