# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=-)\d+x\d+(?=\.[^.]*$)"
test_str = ("https://ensia.com/wp-content/uploads/2020/08/abc_def_ghi-167x378.jpg\n"
"https://ensia.com/wp-content/uploads/2020/08/abc-190x233-def_ghi-127x3278.jpg")
subst = "920x458"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.