using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{StaffMember\.((({(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{[^}{]*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^{])*?)\}";
string input = @"{StaffMember.Surname}
{StaffMember.Child.ToFormattedString(""Hello {FirstName}"")}
{StaffMember.FirstName} {StaffMember.Surname}
Your child is {StaffMember.Child.ToFormattedString(""{FirstName} {Surname}"")}
{Employee.FirstName}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}