package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{StaffMember\.((({(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{(?:(?:{[^}{]*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^}{])*})|[^{])*?)\}`)
var str = `{StaffMember.Surname}
{StaffMember.Child.ToFormattedString("Hello {FirstName}")}
{StaffMember.FirstName} {StaffMember.Surname}
Your child is {StaffMember.Child.ToFormattedString("{FirstName} {Surname}")}
{Employee.FirstName}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}