import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{StaffMember\\.(((\\{(?:(?:\\{(?:(?:\\{(?:(?:\\{(?:(?:\\{(?:(?:\\{(?:(?:\\{(?:(?:\\{(?:(?:\\{[^\\}\\{]*\\})|[^\\}\\{])*\\})|[^\\}\\{])*\\})|[^\\}\\{])*\\})|[^\\}\\{])*\\})|[^\\}\\{])*\\})|[^\\}\\{])*\\})|[^\\}\\{])*\\})|[^\\}\\{])*\\})|[^\\{])*?)\\}";
final String string = "{StaffMember.Surname}\n"
+ "{StaffMember.Child.ToFormattedString(\"Hello {FirstName}\")}\n"
+ "{StaffMember.FirstName} {StaffMember.Surname}\n"
+ "Your child is {StaffMember.Child.ToFormattedString(\"{FirstName} {Surname}\")}\n"
+ "{Employee.FirstName}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}