using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rfi (.*?) .*?\((.*)\)";
string input = @"New RFI 087 (Concrete Beam at Planter)
New RFI 087 (Concrete (Beam) at Planter)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}