package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)rfi (.*?) .*?\((.*)\)`)
var str = `New RFI 087 (Concrete Beam at Planter)
New RFI 087 (Concrete (Beam) at Planter)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}