re = /rfi (.*?) .*?\((.*)\)/mi
str = 'New RFI 087 (Concrete Beam at Planter)
New RFI 087 (Concrete (Beam) at Planter)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end