#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<=[Hh]ello )\w+(?:\s+[\w.]+)*"
Local $sString = "Hello Bob (Marius) Smith." & @CRLF & _
"Hello Bob Jr. (Joseph) White" & @CRLF & _
"Hello Bob Jr. IInd (Paul) Jobs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")