const regex = /(?<=[Hh]ello )\w+(?:\s+[\w.]+)*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[Hh]ello )\\w+(?:\\s+[\\w.]+)*', 'gmi')
const str = `Hello Bob (Marius) Smith.
Hello Bob Jr. (Joseph) White
Hello Bob Jr. IInd (Paul) Jobs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}