re = /(?<=[Hh]ello )\w+(?:\s+[\w.]+)*/mi
str = 'Hello Bob (Marius) Smith.
Hello Bob Jr. (Joseph) White
Hello Bob Jr. IInd (Paul) Jobs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end