#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+:)\s(.*)"
Local $sString = "----INFERENCE TIME----" & @CRLF & _
"" & @CRLF & _
"Note: The first inference on Edge TPU is slow because it includes loading the model into Edge TPU memory." & @CRLF & _
"" & @CRLF & _
"Time: 6.2ms" & @CRLF & _
"" & @CRLF & _
"Results: wall clock" & @CRLF & _
"" & @CRLF & _
"Score: 0.25781" & @CRLF & _
"" & @CRLF & _
"##################################### " & @CRLF & _
"" & @CRLF & _
"labels: imagenet_labels.txt " & @CRLF & _
"" & @CRLF & _
"Model: mobilenet_v1_1.0_224_quant_edgetpu.tflite " & @CRLF & _
"" & @CRLF & _
"Image: img0000.jpg " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")