import re
regex = re.compile(r"(\w+:)\s(.*)", flags=re.MULTILINE)
test_str = ("----INFERENCE TIME----\n\n"
"Note: The first inference on Edge TPU is slow because it includes loading the model into Edge TPU memory.\n\n"
"Time: 6.2ms\n\n"
"Results: wall clock\n\n"
"Score: 0.25781\n\n"
"##################################### \n\n"
"labels: imagenet_labels.txt \n\n"
"Model: mobilenet_v1_1.0_224_quant_edgetpu.tflite \n\n"
"Image: img0000.jpg \n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")