import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+:)\\s(.*)";
final String string = "----INFERENCE TIME----\n\n"
+ "Note: The first inference on Edge TPU is slow because it includes loading the model into Edge TPU memory.\n\n"
+ "Time: 6.2ms\n\n"
+ "Results: wall clock\n\n"
+ "Score: 0.25781\n\n"
+ "##################################### \n\n"
+ "labels: imagenet_labels.txt \n\n"
+ "Model: mobilenet_v1_1.0_224_quant_edgetpu.tflite \n\n"
+ "Image: img0000.jpg \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}