const regex = /^0/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0', 'gm')
const str = `0
1
2
3
4
5
6
7
`;
const subst = `1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);