import Foundation
let pattern = #"^0"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0
1
2
3
4
5
6
7
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)