package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<method>[A-Z]+) (?P<path>[^ ]+) (?P<protocol>[A-Z0-9.\/]+)`)
var str = `----basic-HTTP-request---
GET /tutorials/other/top-20-mysql-best-practices/ HTTP/1.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}