re = /(?P<method>[A-Z]+) (?P<path>[^ ]+) (?P<protocol>[A-Z0-9.\/]+)/m
str = '----basic-HTTP-request---
GET /tutorials/other/top-20-mysql-best-practices/ HTTP/1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end