$re = '/(?P<method>[A-Z]+) (?P<path>[^ ]+) (?P<protocol>[A-Z0-9.\/]+)/m';
$str = '----basic-HTTP-request---
GET /tutorials/other/top-20-mysql-best-practices/ HTTP/1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);