package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4})-(\d{2})-(\d{2})$`)
var str = `2020-26-10`
var substitution = "\1-\3-\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}