$re = '/^(\d{4})-(\d{2})-(\d{2})$/m';
$str = '2020-26-10';
$subst = "\1-\3-\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;