import re
regex = re.compile(r"^(\d{4})-(\d{2})-(\d{2})$", flags=re.MULTILINE)
test_str = "2020-26-10"
subst = "\\1-\\3-\\2"
result = regex.sub(subst, test_str)
if result:
print(result)