using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(.+?\.)(\w+?)\/(\2)";
string input = @"https://www.basler.de/de/beispiel/
https://www.basler.de/at/beispiel/
https://www.basler.at/at/beispiel/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}