re = /https?:\/\/(.+?\.)(\w+?)\/(\2)/m
str = 'https://www.basler.de/de/beispiel/
https://www.basler.de/at/beispiel/
https://www.basler.at/at/beispiel/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end