$re = '/https?:\/\/(.+?\.)(\w+?)\/(\2)/m';
$str = 'https://www.basler.de/de/beispiel/
https://www.basler.de/at/beispiel/
https://www.basler.at/at/beispiel/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);