using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+):\s*(?:""([^""]*)""|(\S+))";
string input = @"sdfd:""dsffs"" dsfd: ""dsf demo"" sfd: dsf fdsff:""fdsfsdf""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}