$re = '/(\w+):\s*(?:"([^"]*)"|(\S+))/m';
$str = 'sdfd:"dsffs" dsfd: "dsf demo" sfd: dsf fdsff:"fdsfsdf"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);