re = /(\w+):\s*(?:"([^"]*)"|(\S+))/m
str = 'sdfd:"dsffs" dsfd: "dsf demo" sfd: dsf fdsff:"fdsfsdf"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end