using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?<=\=).+?((?=\t)|(?=\n))";
        string input = @"=friction_t1!$B$2abc	=friction_t1!$B$3	=friction_t1!$B$4
=friction_t2!$B$2	=friction_t2!$B$3	=friction_t2!$B$4
=friction_t3!$B$2	=friction_t3!$B$3	=friction_t3!$B$4
";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}