use strict;
my $str = '=friction_t1!$B$2abc =friction_t1!$B$3 =friction_t1!$B$4
=friction_t2!$B$2 =friction_t2!$B$3 =friction_t2!$B$4
=friction_t3!$B$2 =friction_t3!$B$3 =friction_t3!$B$4
';
my $regex = qr/(?<=\=).+?((?=\t)|(?=\n))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}