package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a](b)`)
var str = `abba
dbcd
bacdba
bacd
adfjldb
dkfjb
abdfdsba
ab ba abdkfjdk bacdk dkekfba`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}