import re
regex = re.compile(r"[^a](b)")
test_str = ("abba \n"
"dbcd \n"
"bacdba \n"
"bacd \n"
"adfjldb \n"
"dkfjb\n"
"abdfdsba\n"
"ab ba abdkfjdk bacdk dkekfba")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")