// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^a](b)").unwrap();
let string = "abba
dbcd
bacdba
bacd
adfjldb
dkfjb
abdfdsba
ab ba abdkfjdk bacdk dkekfba";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}