#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w*ab\w*|(\w*b\w*)"
Local $sString = "abba " & @CRLF & _
"dbcd " & @CRLF & _
"bacdba " & @CRLF & _
"bacd " & @CRLF & _
"adfjldb " & @CRLF & _
"dkfjb" & @CRLF & _
"abdfdsba" & @CRLF & _
"ab ba abdkfjdk bacdk dkekfba"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")