using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w*ab\w*|(\w*b\w*)";
string input = @"abba
dbcd
bacdba
bacd
adfjldb
dkfjb
abdfdsba
ab ba abdkfjdk bacdk dkekfba";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}