re = /\w*ab\w*|(\w*b\w*)/
str = 'abba
dbcd
bacdba
bacd
adfjldb
dkfjb
abdfdsba
ab ba abdkfjdk bacdk dkekfba'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end