use strict;
my $str = 'Stack overflow is the best? I am also the best.';
my $regex = qr/^.*?[.?!]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";